GHSA-v973-fxgf-6xhp
mako is vulnerable to Regular Expression Denial of Service
At a glance
- Published
- Updated
- CVE
- CVE-2022-40023
- Aliases
- PYSEC-2022-260
- CVSS_V3
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- CVSS_V4
- CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N
Description
Sqlalchemy mako before 1.2.2 is vulnerable to Regular expression Denial of Service when using the Lexer class to parse. This also affects babelplugin and linguaplugin.
Affected packages
| Package | Versions |
|---|---|
| PyPI · mako | introduced 0, fixed 1.2.2 |
References
- https://nvd.nist.gov/vuln/detail/CVE-2022-40023 ADVISORY
- https://github.com/sqlalchemy/mako/issues/366 WEB
- https://github.com/sqlalchemy/mako/commit/925760291d6efec64fda6e9dd1fd9cfbd5be068c WEB
- https://github.com/advisories/GHSA-v973-fxgf-6xhp ADVISORY
- https://github.com/pypa/advisory-database/tree/main/vulns/mako/PYSEC-2022-260.yaml WEB
- https://github.com/sqlalchemy/mako WEB
- https://github.com/sqlalchemy/mako/blob/c2f392e0be52dc67d1b9770ab8cce6a9c736d547/mako/ext/extract.py#L21 WEB
- https://lists.debian.org/debian-lts-announce/2022/09/msg00026.html WEB
- https://lists.debian.org/debian-lts-announce/2025/12/msg00004.html WEB
- https://pyup.io/posts/pyup-discovers-redos-vulnerabilities-in-top-python-packages WEB
- https://pyup.io/vulnerabilities/CVE-2022-40023/50870 WEB
Sources
| Source | Licence |
|---|---|
| OSV.dev | CC-BY 4.0 — GitHub Advisory Database |