GHSA-v682-8vv8-vpwr

Denial of Service via incomplete cleanup vulnerability in Apache Tomcat

At a glance

Published
Updated
CVE
CVE-2024-23672
Aliases
BIT-tomcat-2024-23672
CVSS_V3
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L

Description

Denial of Service via incomplete cleanup vulnerability in Apache Tomcat. It was possible for WebSocket clients to keep WebSocket connections open leading to increased resource consumption.This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.0-M16, from 10.1.0-M1 through 10.1.18, from 9.0.0-M1 through 9.0.85, from 8.5.0 through 8.5.98. Older, EOL versions may also be affected. Users are recommended to upgrade to version 11.0.0-M17, 10.1.19, 9.0.86 or 8.5.99 which fix the issue.

Affected packages

PackageVersions
Maven · org.apache.tomcat:tomcat-websocketintroduced 11.0.0-M1, fixed 11.0.0-M17
Maven · org.apache.tomcat:tomcat-websocketintroduced 10.1.0-M1, fixed 10.1.19
Maven · org.apache.tomcat:tomcat-websocketintroduced 9.0.0-M1, fixed 9.0.86
Maven · org.apache.tomcat:tomcat-websocketintroduced 8.5.0, fixed 8.5.99
Maven · org.apache.tomcat.embed:tomcat-embed-websocketintroduced 11.0.0-M1, fixed 11.0.0-M17
Maven · org.apache.tomcat.embed:tomcat-embed-websocketintroduced 10.1.0-M1, fixed 10.1.19
Maven · org.apache.tomcat.embed:tomcat-embed-websocketintroduced 9.0.0-M1, fixed 9.0.86
Maven · org.apache.tomcat.embed:tomcat-embed-websocketintroduced 8.5.0, fixed 8.5.99

References

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database