GHSA-v5rq-w2xm-7g5f

Improper Access Control in MySQL Connector Python

At a glance

Published
Updated
CVE
CVE-2019-2435
Aliases
PYSEC-2026-683
CVSS_V3
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:N

Description

Vulnerability in the MySQL Connectors component of Oracle MySQL (subcomponent: Connector/Python). Supported versions that are affected are 8.0.13 and prior and 2.1.8 and prior. Easily exploitable vulnerability allows unauthenticated attacker with network access via TLS to compromise MySQL Connectors. Successful attacks require human interaction from a person other than the attacker. Successful attacks of this vulnerability can result in unauthorized creation, deletion or modification access to critical data or all MySQL Connectors accessible data as well as unauthorized access to critical data or complete access to all MySQL Connectors accessible data.

Affected packages

PackageVersions
PyPI · mysql-connector-pythonintroduced 8.0.0, fixed 8.0.19
PyPI · mysql-connector-pythonintroduced 2.1.0, last affected 2.1.8

References

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database