GHSA-v5m6-2m78-4vr2

Magento 2 Community Edition XSS Vulnerability

At a glance

Published
Updated
CVE
CVE-2019-7877
CVSS_V3
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

Description

A stored cross-site scripting vulnerability exists in the admin panel of Magento 2.1 prior to 2.1.18, Magento 2.2 prior to 2.2.9, Magento 2.3 prior to 2.3.2. An authenticated user with privileges to manage orders can inject malicious javascript.

Affected packages

PackageVersions
Packagist · magento/community-editionintroduced 2.1, fixed 2.1.18
Packagist · magento/community-editionintroduced 2.2, fixed 2.2.9
Packagist · magento/community-editionintroduced 2.3, fixed 2.3.2

References

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database