GHSA-v525-c3g5-cg9p

Unsafe Deserialization that can Result in Code Execution

At a glance

Published
Updated
CVE
CVE-2020-36282

Description

JMS Client for RabbitMQ 1.x before 1.15.2 and 2.x before 2.2.0 is vulnerable to unsafe deserialization that can result in code execution via crafted StreamMessage data.

Affected packages

PackageVersions
Maven · com.rabbitmq.jms:rabbitmq-jmsintroduced 2.0, fixed 2.2.0
Maven · com.rabbitmq.jms:rabbitmq-jmsintroduced 1.0, fixed 1.15.2

References

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database