GHSA-v4f8-2847-rwm7

Nokogiri Implements libxml2 version vulnerable to use-after-free

En bref

Publiée
Mise à jour
CVE
CVE-2021-3518
CVSS_V3
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Description

There's a flaw in libxml2 in versions before 2.9.11. An attacker who is able to submit a crafted file to be processed by an application linked with libxml2 could trigger a use-after-free. The greatest impact from this flaw is to confidentiality, integrity, and availability.

Paquets affectés

PaquetVersions
RubyGems · nokogiriintroduced 0, fixed 1.11.4

Références

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database