GHSA-v3c5-jqr6-7qm8

Python Charmers Future denial of service vulnerability

At a glance

Published
Updated
CVE
CVE-2022-40899
Aliases
PYSEC-2022-42991
CVSS_V3
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
CVSS_V4
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N

Description

An issue discovered in Python Charmers Future 0.18.2 and earlier allows remote attackers to cause a denial of service via crafted Set-Cookie header from malicious web server. This issue has been patched in version 0.18.3.

Affected packages

PackageVersions
PyPI · futureintroduced 0, fixed 0.18.3

References

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database