GHSA-v33x-prhc-gph5
Insufficiently Protected Credentials and Improper Authentication in Spring Security
At a glance
- Published
- Updated
- CVE
- CVE-2019-11272
- CVSS_V3
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L
Description
Spring Security, versions 4.2.x up to 4.2.12, and older unsupported versions support plain text passwords using PlaintextPasswordEncoder. If an application using an affected version of Spring Security is leveraging PlaintextPasswordEncoder and a user has a null encoded password, a malicious user (or attacker) can authenticate using a password of ?null?.
Affected packages
| Package | Versions |
|---|---|
| Maven · org.springframework.security:spring-security-core | introduced 0, fixed 4.2.13 |
| Maven · org.springframework.security:spring-security-cas | introduced 0, fixed 4.2.13.RELEASE |
References
- https://nvd.nist.gov/vuln/detail/CVE-2019-11272 ADVISORY
- https://lists.debian.org/debian-lts-announce/2019/07/msg00008.html WEB
- https://pivotal.io/security/cve-2019-11272 WEB
Sources
| Source | Licence |
|---|---|
| OSV.dev | CC-BY 4.0 — GitHub Advisory Database |