GHSA-v2rg-8cwr-75g8

Deserializer tampering in Apache Dubbo

At a glance

Published
Updated
CVE
CVE-2021-25641
CVSS_V3
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Description

Each Apache Dubbo server will set a serialization id to tell the clients which serialization protocol it is working on. But for Dubbo versions before 2.7.8 or 2.6.9, an attacker can choose which serialization id the Provider will use by tampering with the byte preamble flags, aka, not following the server's instruction. This means that if a weak deserializer such as the Kryo and FST are somehow in code scope (e.g. if Kryo is somehow a part of a dependency), a remote unauthenticated attacker can tell the Provider to use the weak deserializer, and then proceed to exploit it.

Affected packages

PackageVersions
Maven · org.apache.dubbo:dubbointroduced 2.5.0, fixed 2.7.8
Maven · com.alibaba:dubbointroduced 2.5.0, fixed 2.6.9

References

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database