GHSA-rvqx-wpfh-mfx7
Langflow Unauth RCE
En bref
- Publiée
- Mise à jour
- CVE
- CVE-2025-3248
- Alias
- PYSEC-2025-36, PYSEC-2026-380
- CVSS_V4
- CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:A
Description
Langflow versions prior to 1.3.0 are susceptible to code injection in the /api/v1/validate/code endpoint. A remote and unauthenticated attacker can send crafted HTTP requests to execute arbitrary code.
Paquets affectés
| Paquet | Versions |
|---|---|
| PyPI · langflow | introduced 0, fixed 1.3.0 |
| PyPI · langflow-base | introduced 0, fixed 0.3.0 |
Références
- https://github.com/langflow-ai/langflow/security/advisories/GHSA-rvqx-wpfh-mfx7 WEB
- https://nvd.nist.gov/vuln/detail/CVE-2025-3248 ADVISORY
- https://github.com/langflow-ai/langflow/pull/6911 WEB
- https://github.com/langflow-ai/langflow/commit/faac4db133de32fcb6d483fa9ff52f40ce42bdc0 WEB
- https://github.com/langflow-ai/langflow PACKAGE
- https://github.com/langflow-ai/langflow/releases/tag/1.3.0 WEB
- https://github.com/pypa/advisory-database/tree/main/vulns/langflow-base/PYSEC-2026-380.yaml WEB
- https://pypi.org/project/langflow-base WEB
- https://www.cisa.gov/known-exploited-vulnerabilities-catalog?field_cve=CVE-2025-3248 WEB
- https://www.horizon3.ai/attack-research/disclosures/unsafe-at-any-speed-abusing-python-exec-for-unauth-rce-in-langflow-ai WEB
- https://www.vulncheck.com/advisories/langflow-unauthenticated-rce WEB
Sources
| Source | Licence |
|---|---|
| OSV.dev | CC-BY 4.0 — GitHub Advisory Database |