GHSA-rvmc-8gmg-ggqr
Moodle Blind SQL injection possible via MNet authentication
At a glance
- Published
- Updated
- CVE
- CVE-2021-32474
- Aliases
- BIT-moodle-2021-32474
- CVSS_V3
- CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H
Description
An SQL injection risk existed on sites with MNet enabled and configured, via an XML-RPC call from the connected peer host. Note that this required site administrator access or access to the keypair. Moodle 3.10 to 3.10.3, 3.9 to 3.9.6, 3.8 to 3.8.8, 3.5 to 3.5.17 and earlier unsupported versions are affected.
Affected packages
| Package | Versions |
|---|---|
| Packagist · moodle/moodle | introduced 3.10, fixed 3.10.4 |
| Packagist · moodle/moodle | introduced 3.9, fixed 3.9.7 |
| Packagist · moodle/moodle | introduced 3.8, fixed 3.8.9 |
| Packagist · moodle/moodle | introduced 3.5, fixed 3.5.18 |
References
- https://nvd.nist.gov/vuln/detail/CVE-2021-32474 ADVISORY
- https://github.com/moodle/moodle PACKAGE
- https://moodle.org/mod/forum/discuss.php?d=422308 WEB
Sources
| Source | Licence |
|---|---|
| OSV.dev | CC-BY 4.0 — GitHub Advisory Database |