GHSA-rv39-3qh7-9v7w

Improper Input Validation in Spring Framework

At a glance

Published
Updated
CVE
CVE-2020-5421
CVSS_V3
CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:C/C:L/I:H/A:N

Description

In Spring Framework versions 5.2.0 - 5.2.8, 5.1.0 - 5.1.17, 5.0.0 - 5.0.18, 4.3.0 - 4.3.28, and older unsupported versions, the protections against RFD attacks from CVE-2015-5211 may be bypassed depending on the browser used through the use of a jsessionid path parameter.

Affected packages

PackageVersions
Maven · org.springframework:spring-framework-bomintroduced 5.2.0, fixed 5.2.9
Maven · org.springframework:spring-framework-bomintroduced 5.1.0, fixed 5.1.18
Maven · org.springframework:spring-framework-bomintroduced 5.0.0, fixed 5.0.19
Maven · org.springframework:spring-framework-bomintroduced 0, fixed 4.3.29

References

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database