GHSA-rv25-9wgj-xg75

Apache Airflow Reflected Cross-site Scripting vulnerability in 404 Endpoint

At a glance

Published
Updated
CVE
CVE-2017-12614
Aliases
PYSEC-2018-45
CVSS_V3
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
CVSS_V4
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N

Description

It was noticed an XSS in certain 404 pages that could be exploited to perform an XSS attack. Chrome will detect this as a reflected XSS attempt and prevent the page from loading. However Firefox and other browsers don't, and are vulnerable to this attack. Mitigation: The fix for this is to upgrade to Apache Airflow 1.9.0 or above.

Affected packages

PackageVersions
PyPI · apache-airflowintroduced 0, fixed 1.9.0

References

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database