GHSA-rrj2-ph5q-jxw2
jquery-validation vulnerable to Cross-site Scripting
At a glance
- Published
- Updated
- CVE
- CVE-2025-3573
- CVSS_V3
- CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- CVSS_V4
- CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:L/VA:N/SC:L/SI:L/SA:N
Description
Versions of the package jquery-validation before 1.20.0 are vulnerable to Cross-site Scripting (XSS) in the showLabel() function, which may take input from a user-controlled placeholder value. This value will populate a message via $.validator.messages in a user localizable dictionary.
Affected packages
| Package | Versions |
|---|---|
| npm · jquery-validation | introduced 0, fixed 1.20.0 |
References
- https://nvd.nist.gov/vuln/detail/CVE-2025-3573 ADVISORY
- https://github.com/jquery-validation/jquery-validation/pull/2462 WEB
- https://github.com/jquery-validation/jquery-validation/commit/7a490d8f39bd988027568ddcf51755e1f4688902 WEB
- https://github.com/jquery-validation/jquery-validation PACKAGE
- https://security.snyk.io/vuln/SNYK-JS-JQUERYVALIDATION-5952285 WEB
Sources
| Source | Licence |
|---|---|
| OSV.dev | CC-BY 4.0 — GitHub Advisory Database |