GHSA-rrfq-g5fq-fc9c

Improper Authentication in hive:hive-exec

At a glance

Published
Updated
CVE
CVE-2018-11777
CVSS_V3
CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N

Description

In Apache Hive 2.3.3, 3.1.0 and earlier, local resources on HiveServer2 machines are not properly protected against malicious user if ranger, sentry or sql standard authorizer is not in use.

Affected packages

PackageVersions
Maven · org.apache.hive:hive-execintroduced 3.0.0, fixed 3.1.1
Maven · org.apache.hive:hive-execintroduced 0, fixed 2.3.4

References

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database