GHSA-rrfq-g5fq-fc9c
Improper Authentication in hive:hive-exec
At a glance
- Published
- Updated
- CVE
- CVE-2018-11777
- CVSS_V3
- CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N
Description
In Apache Hive 2.3.3, 3.1.0 and earlier, local resources on HiveServer2 machines are not properly protected against malicious user if ranger, sentry or sql standard authorizer is not in use.
Affected packages
| Package | Versions |
|---|---|
| Maven · org.apache.hive:hive-exec | introduced 3.0.0, fixed 3.1.1 |
| Maven · org.apache.hive:hive-exec | introduced 0, fixed 2.3.4 |
References
- https://nvd.nist.gov/vuln/detail/CVE-2018-11777 ADVISORY
- https://github.com/advisories/GHSA-rrfq-g5fq-fc9c ADVISORY
- https://lists.apache.org/thread.html/963c8e2516405c9b532b4add16c03b2c5db621e0c83e80f45049cbbb@%3Cdev.hive.apache.org%3E WEB
- http://www.securityfocus.com/bid/105886 WEB
Sources
| Source | Licence |
|---|---|
| OSV.dev | CC-BY 4.0 — GitHub Advisory Database |