GHSA-rprw-h62v-c2w7

PyYAML insecurely deserializes YAML strings leading to arbitrary code execution

At a glance

Published
Updated
CVE
CVE-2017-18342
Aliases
PYSEC-2018-49
CVSS_V3
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Description

In PyYAML before 5.1, the `yaml.load()` API could execute arbitrary code. In other words, `yaml.safe_load` is not used. This was intended to be fixed in 4.1, but due to [breaking changes](https://github.com/yaml/pyyaml/issues/192#issuecomment-401491470), 4.1 was yanked and 5.1 [contains](https://github.com/yaml/pyyaml/issues/207#issuecomment-472520007) the patch for CVE-2017-18342.

Affected packages

PackageVersions
PyPI · pyyamlintroduced 0, fixed 5.1

References

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database