GHSA-rp46-r563-jrc7

Apache Avro Java SDK is Vulnerable to Code Injection

En bref

Publiée
Mise à jour
CVE
CVE-2025-33042
Alias
PYSEC-2026-26
CVSS_V4
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N

Description

Improper Control of Generation of Code ('Code Injection') vulnerability in Apache Avro Java SDK when generating specific records from untrusted Avro schemas. This issue affects Apache Avro Java SDK: all versions through 1.11.4 and version 1.12.0. Users are recommended to upgrade to version 1.12.1 or 1.11.5, which fix the issue.

Paquets affectés

PaquetVersions
Maven · org.apache.avro:avro-compilerintroduced 1.12.0, fixed 1.12.1
Maven · org.apache.avro:avro-compilerintroduced 0, fixed 1.11.5

Références

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database