GHSA-rm97-x556-q36h

sanitize-html Information Exposure vulnerability

En bref

Publiée
Mise à jour
CVE
CVE-2024-21501
CVSS_V3
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N

Description

Versions of the package sanitize-html before 2.12.1 are vulnerable to Information Exposure when used on the backend and with the style attribute allowed, allowing enumeration of files in the system (including project dependencies). An attacker could exploit this vulnerability to gather details about the file system structure and dependencies of the targeted server.

Paquets affectés

PaquetVersions
npm · sanitize-htmlintroduced 0, fixed 2.12.1

Références

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database