GHSA-rm79-x4g6-hvg5
pgAdmin 4 has command injection vulnerability on Windows systems
At a glance
- Published
- Updated
- CVE
- CVE-2025-12763
- Aliases
- PYSEC-2026-1776
- CVSS_V3
- CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:U/C:H/I:H/A:H
Description
pgAdmin 4 versions up to 9.9 are affected by a command injection vulnerability on Windows systems. This issue is caused by the use of shell=True during backup and restore operations, enabling attackers to execute arbitrary system commands by providing specially crafted file path input.
Affected packages
| Package | Versions |
|---|---|
| PyPI · pgadmin4 | introduced 0, fixed 9.10 |
References
- https://nvd.nist.gov/vuln/detail/CVE-2025-12763 ADVISORY
- https://github.com/pgadmin-org/pgadmin4/issues/9323 WEB
- https://github.com/pgadmin-org/pgadmin4/commit/e374edc69239b3e02ecde895e27d9f9e488b87ee WEB
- https://github.com/pgadmin-org/pgadmin4 PACKAGE
Sources
| Source | Licence |
|---|---|
| OSV.dev | CC-BY 4.0 — GitHub Advisory Database |