GHSA-rj4f-cp4v-hvcv

Magento Blind SQL Injection in the Search module

At a glance

Published
Updated
CVE
CVE-2021-21024
Aliases
BIT-magento-2021-21024
CVSS_V3
CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:H/I:H/A:H

Description

Magento versions 2.4.1 (and earlier), 2.4.0-p1 (and earlier) and 2.3.6 (and earlier) are affected by a blind SQL injection vulnerability in the Search module. Successful exploitation could lead to unauthorized access to restricted resources by an unauthenticated attacker. Access to the admin console is required for successful exploitation.

Affected packages

PackageVersions
Packagist · magento/community-editionintroduced 0, fixed 2.3.6-p1
Packagist · magento/community-editionintroduced 2.4.0, fixed 2.4.1-p1

References

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database