GHSA-rhx9-3qf7-r3j7

Drupal Remote code execution

En bref

Publiée
Mise à jour
CVE
CVE-2017-6381
CVSS_V3
CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H

Description

A 3rd party development library including with Drupal 8 development dependencies is vulnerable to remote code execution. This is mitigated by the default .htaccess protection against PHP execution, and the fact that Composer development dependencies aren't normal installed. You might be vulnerable to this if you are running a version of Drupal before 8.2.2. To be sure you aren't vulnerable, you can remove the <siteroot>/vendor/phpunit directory from your production deployments

Paquets affectés

PaquetVersions
Packagist · drupal/coreintroduced 8.0, fixed 8.2.7
Packagist · drupal/drupalintroduced 8.0, fixed 8.2.7

Références

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database