GHSA-rgx6-rjj4-c388

ckeditor4 vulnerable to cross-site scripting

En bref

Publiée
Mise à jour
CVE
CVE-2021-33829
Alias
BIT-drupal-2021-33829, DRUPAL-CORE-2021-003
CVSS_V3
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

Description

A cross-site scripting (XSS) vulnerability in the HTML Data Processor in CKEditor 4 4.14.0 through 4.16.x before 4.16.1 allows remote attackers to inject executable JavaScript code through a crafted comment because `--!>` is mishandled.

Paquets affectés

PaquetVersions
npm · ckeditor4introduced 4.14.0, fixed 4.16.1
Packagist · drupal/coreintroduced 7.0.0, fixed 7.80
Packagist · drupal/coreintroduced 8.0.0, fixed 8.9.16
Packagist · drupal/coreintroduced 9.0.0, fixed 9.0.14
Packagist · drupal/coreintroduced 9.1.0, fixed 9.1.9
Packagist · drupal/drupalintroduced 7.0.0, fixed 7.80
Packagist · drupal/drupalintroduced 8.0.0, fixed 8.9.16
Packagist · drupal/drupalintroduced 9.0.0, fixed 9.0.14
Packagist · drupal/drupalintroduced 9.1.0, fixed 9.1.9

Références

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database