GHSA-rc7h-x6cq-988q

Improper Input Validation in JGroups

En bref

Publiée
Mise à jour
CVE
CVE-2016-2141
CVSS_V3
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Description

JGroups before 4.0 does not require the proper headers for the ENCRYPT and AUTH protocols from nodes joining the cluster, which allows remote attackers to bypass security restrictions and send and receive messages within the cluster via unspecified vectors. Fixes for this issue have been backported to versions 3.6.10.Final and 3.2.16.Final.

Paquets affectés

PaquetVersions
Maven · org.jgroups:jgroupsintroduced 3.3.0.Alpha1, fixed 3.6.10.Final
Maven · org.jgroups:jgroupsintroduced 0, fixed 3.2.16.Final

Références

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database