GHSA-r9v2-gg2j-22q5
Payload: Insufficient Access Control in Stripe REST Proxy
En bref
- Publiée
- Mise à jour
- CVE
- CVE-2026-105848
- CVSS_V4
- CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:N/SC:H/SI:H/SA:N
Description
## Impact An authenticated user could perform unintended Stripe operations through the optional Stripe REST proxy. **You are affected if ALL of these are true:** - Your application uses `@payloadcms/plugin-stripe`. - The optional Stripe REST proxy is enabled. - An authenticated user can reach the proxy. Deployments that do not enable the Stripe REST proxy are not affected. ## Patches Users should upgrade Payload packages to `>= 3.90.0` or `>= 4.0.0-canary.34`. ## Workarounds Upgrading to a patched version is recommended. If you cannot upgrade immediately, disable the Stripe REST proxy. If it must remain enabled, restrict access to trusted users and only the required Stripe operations.
Paquets affectés
| Paquet | Versions |
|---|---|
| npm · @payloadcms/plugin-stripe | introduced 0, fixed 3.90.0 |
| npm · @payloadcms/plugin-stripe | introduced 4.0.0-canary.0, fixed 4.0.0-canary.34 |
Références
- https://github.com/payloadcms/payload/security/advisories/GHSA-r9v2-gg2j-22q5 WEB
- https://github.com/payloadcms/payload/commit/2f94a4205e5ba3ec0e91c92ed54f24f429826dd0 WEB
- https://github.com/payloadcms/payload PACKAGE
- https://github.com/payloadcms/payload/releases/tag/v3.90.0 WEB
Sources
| Source | Licence |
|---|---|
| OSV.dev | CC-BY 4.0 — GitHub Advisory Database |