GHSA-r9px-m959-cxf4
go-git clients vulnerable to DoS via maliciously crafted Git server replies
At a glance
- Published
- Updated
- CVE
- CVE-2025-21614
- Aliases
- GO-2025-3367
- CVSS_V3
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Description
### Impact A denial of service (DoS) vulnerability was discovered in go-git versions prior to `v5.13`. This vulnerability allows an attacker to perform denial of service attacks by providing specially crafted responses from a Git server which triggers resource exhaustion in `go-git` clients. This is a `go-git` implementation issue and does not affect the upstream `git` cli. ### Patches Users running versions of `go-git` from `v4` and above are recommended to upgrade to `v5.13` in order to mitigate this vulnerability. ### Workarounds In cases where a bump to the latest version of `go-git` is not possible, we recommend limiting its use to only trust-worthy Git servers. ## Credit Thanks to Ionut Lalu for responsibly disclosing this vulnerability to us.
Affected packages
| Package | Versions |
|---|---|
| Go · gopkg.in/src-d/go-git.v4 | introduced 4.0.0, last affected 4.13.1 |
| Go · github.com/go-git/go-git/v5 | introduced 0, fixed 5.13.0 |
| Go · github.com/go-git/go-git | introduced 4.0.0, last affected 4.13.1 |
References
- https://github.com/go-git/go-git/security/advisories/GHSA-r9px-m959-cxf4 WEB
- https://nvd.nist.gov/vuln/detail/CVE-2025-21614 ADVISORY
- https://github.com/go-git/go-git PACKAGE
Sources
| Source | Licence |
|---|---|
| OSV.dev | CC-BY 4.0 — GitHub Advisory Database |