GHSA-r9hx-vwmv-q579

pypa/setuptools vulnerable to Regular Expression Denial of Service (ReDoS)

At a glance

Published
Updated
CVE
CVE-2022-40897
Aliases
BIT-setuptools-2022-40897, PYSEC-2022-43012
CVSS_V3
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
CVSS_V4
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:L/SI:L/SA:N

Description

Python Packaging Authority (PyPA)'s setuptools is a library designed to facilitate packaging Python projects. Setuptools version 65.5.0 and earlier could allow remote attackers to cause a denial of service by fetching malicious HTML from a PyPI package or custom PackageIndex page due to a vulnerable Regular Expression in `package_index`. This has been patched in version 65.5.1.

Affected packages

PackageVersions
PyPI · setuptoolsintroduced 0, fixed 65.5.1

References

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database