GHSA-r7x6-xfcm-3mxv

Apache Airflow vulnerable to Exposure of Sensitive Information to an Unauthorized Actor

At a glance

Published
Updated
CVE
CVE-2023-42781
Aliases
BIT-airflow-2023-42781, PYSEC-2023-231
CVSS_V3
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
CVSS_V4
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N

Description

Apache Airflow, versions before 2.7.3, has a vulnerability that allows an authorized user who has access to read specific DAGs only, to read information about task instances in other DAGs.  This is a different issue than CVE-2023-42663 but leading to similar outcome. Users of Apache Airflow are advised to upgrade to version 2.7.3 or newer to mitigate the risk associated with this vulnerability.

Affected packages

PackageVersions
PyPI · apache-airflowintroduced 0, fixed 2.7.3

References

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database