GHSA-r7c9-c69m-rph8

Code Injection in PHPUnit

En bref

Publiée
Mise à jour
CVE
CVE-2017-9841
CVSS_V3
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H/E:H

Description

Util/PHP/eval-stdin.php in PHPUnit starting with 4.8.19 and before 4.8.28, as well as 5.x before 5.6.3, allows remote attackers to execute arbitrary PHP code via HTTP POST data beginning with a `<?php ` substring, as demonstrated by an attack on a site with an exposed /vendor folder, i.e., external access to the /vendor/phpunit/phpunit/src/Util/PHP/eval-stdin.php URI.

Paquets affectés

PaquetVersions
Packagist · phpunit/phpunitintroduced 4.8.19, fixed 4.8.28
Packagist · phpunit/phpunitintroduced 5.0.10, fixed 5.6.3

Références

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database