GHSA-r5fx-8r73-v86c
AngularJS Cross-site Scripting due to failure to sanitize `xlink.href` attributes
En bref
- Publiée
- Mise à jour
- CVE
- CVE-2019-14863
- CVSS_V3
- CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Description
Versions of `angular` prior to 1.5.0-beta.1 are vulnerable to Cross-Site Scripting. The package fails to sanitize `xlink:href` attributes, which may allow attackers to execute arbitrary JavaScript in a victim's browser if the value is user-controlled. ## Recommendation Upgrade to version 1.5.0-beta.1 or later.
Paquets affectés
| Paquet | Versions |
|---|---|
| npm · angular | introduced 0, fixed 1.5.0-beta.1 |
Références
- https://nvd.nist.gov/vuln/detail/CVE-2019-14863 ADVISORY
- https://github.com/angular/angular.js/pull/12524 WEB
- https://github.com/angular/angular.js/commit/35a21532b73d5bd84b4325211c563e6a3e2dde82 WEB
- https://github.com/angular/angular.js/commit/f33ce173c90736e349cf594df717ae3ee41e0f7a WEB
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2019-14863 WEB
- https://github.com/angular/angular.js PACKAGE
- https://snyk.io/vuln/npm:angular:20150807 WEB
- https://www.npmjs.com/advisories/1453 WEB
Sources
| Source | Licence |
|---|---|
| OSV.dev | CC-BY 4.0 — GitHub Advisory Database |