GHSA-r4q3-7g4q-x89m
Spring Framework server Web DoS Vulnerability
At a glance
- Published
- Updated
- CVE
- CVE-2024-22233
- CVSS_V3
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Description
In Spring Framework versions 6.0.15 and 6.1.2, it is possible for a user to provide specially crafted HTTP requests that may cause a denial-of-service (DoS) condition. Specifically, an application is vulnerable when all of the following are true: * the application uses Spring MVC * Spring Security 6.1.6+ or 6.2.1+ is on the classpath Typically, Spring Boot applications need the org.springframework.boot:spring-boot-starter-web and org.springframework.boot:spring-boot-starter-security dependencies to meet all conditions.
Affected packages
| Package | Versions |
|---|---|
| Maven · org.springframework:spring-core | introduced 6.1.2, fixed 6.1.3 |
| Maven · org.springframework:spring-core | introduced 6.0.15, fixed 6.0.16 |
References
- https://nvd.nist.gov/vuln/detail/CVE-2024-22233 ADVISORY
- https://security.netapp.com/advisory/ntap-20240614-0005 WEB
- https://spring.io/security/cve-2024-22233 WEB
Sources
| Source | Licence |
|---|---|
| OSV.dev | CC-BY 4.0 — GitHub Advisory Database |