GHSA-r4hh-pcgx-j5r2

Flowise: Authenticated Command Execution and Sandbox Bypass via Puppeteer and Playwright Packages

At a glance

Published
Updated
CVE
CVE-2025-34267
Aliases
GHSA-5w3r-f6gm-c25w
CVSS_V4
CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:H/VI:L/VA:L/SC:H/SI:H/SA:L

Description

Flowise v3.0.1 < 3.0.8 and all versions after with 'ALLOW_BUILTIN_DEP' enabled contain an authenticated remote code execution vulnerability and node VM sandbox escape due to insecure use of integrated modules (Puppeteer and Playwright) within the nodevm execution environment. An authenticated attacker able to create or run a tool that leverages Puppeteer/Playwright can specify attacker-controlled browser binary paths and parameters. When the tool executes, the attacker-controlled executable/parameters are run on the host and circumvent the intended nodevm sandbox restrictions, resulting in execution of arbitrary code in the context of the host. **NOTE**: This vulnerability was incorrectly assigned as a duplicate CVE-2025-26319 and should be considered distinct from that identifier.

Affected packages

PackageVersions
npm · flowiseintroduced 3.0.1, fixed 3.0.8

References

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database