GHSA-r3hx-qfh5-r9m7

Elasticsearch Incorrect Authorization vulnerability

At a glance

Published
Updated
CVE
CVE-2024-23451
Aliases
BIT-elasticsearch-2024-23451
CVSS_V3
CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:U/C:H/I:N/A:N

Description

Incorrect Authorization issue exists in the API key based security model for Remote Cluster Security, which is currently in Beta, in Elasticsearch 8.10.0 and before 8.13.0. This allows a malicious user with a valid API key for a remote cluster configured to use the new Remote Cluster Security to read arbitrary documents from any index on the remote cluster, and only if they use the Elasticsearch custom transport protocol to issue requests with the target index ID, the shard ID and the document ID. None of Elasticsearch REST API endpoints are affected by this issue.

Affected packages

PackageVersions
Maven · org.elasticsearch:elasticsearchintroduced 8.10.0, fixed 8.13.0

References

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database