GHSA-r2f6-6928-fh8f

Apache Airflow Spark Provider Improper Input Validation vulnerability

En bref

Publiée
Mise à jour
CVE
CVE-2023-40272
Alias
PYSEC-2026-1141
CVSS_V3
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N

Description

Apache Airflow Spark Provider, versions before 4.1.3, is affected by a vulnerability that allows an attacker to pass in malicious parameters when establishing a connection giving an opportunity to read files on the Airflow server. It is recommended to upgrade to a version that is not affected.

Paquets affectés

PaquetVersions
PyPI · apache-airflow-providers-apache-sparkintroduced 0, fixed 4.1.3

Références

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database