GHSA-r29w-r9ph-vm76

Apache XML Graphics Batik vulnerable to code execution via SVG.

At a glance

Published
Updated
CVE
CVE-2022-41704
CVSS_V3
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N

Description

A vulnerability in Batik of Apache XML Graphics allows an attacker to run untrusted Java code from an SVG. This issue affects Apache XML Graphics prior to 1.16. It is recommended to update to version 1.16.

Affected packages

PackageVersions
Maven · org.apache.xmlgraphics:batikintroduced 0, fixed 1.16

References

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database