GHSA-qxpc-96fq-wwmg
Apache Cassandra is vulnerable to privilege escalation in an mTLS environment using MutualTlsAuthenticator
At a glance
- Published
- Updated
- CVE
- CVE-2026-27314
- CVSS_V3
- CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Description
Privilege escalation in Apache Cassandra 5.0 on an mTLS environment using MutualTlsAuthenticator allows a user with only CREATE permission to associate their own certificate identity with an arbitrary role, including a superuser role, and authenticate as that role via ADD IDENTITY. Users are recommended to upgrade to version 5.0.7+, which fixes this issue.
Affected packages
| Package | Versions |
|---|---|
| Maven · org.apache.cassandra:cassandra-all | introduced 5.0-alpha1, fixed 5.0.7 |
References
- https://nvd.nist.gov/vuln/detail/CVE-2026-27314 ADVISORY
- https://github.com/apache/cassandra/commit/b584a435970e5125e1def5148d943c39569dc7af WEB
- https://github.com/apache/cassandra PACKAGE
- https://github.com/apache/cassandra/releases/tag/cassandra-5.0.7 WEB
- https://lists.apache.org/thread/zrng82ddy4rpsmfyk582v6hqxcqrbz7f WEB
- http://www.openwall.com/lists/oss-security/2026/04/07/7 WEB
Sources
| Source | Licence |
|---|---|
| OSV.dev | CC-BY 4.0 — GitHub Advisory Database |