GHSA-qrpm-p2h7-hrv2

Exposure of Sensitive Information to an Unauthorized Actor in nanoid

At a glance

Published
Updated
CVE
CVE-2021-23566
CVSS_V3
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N

Description

The package nanoid from 3.0.0, before 3.1.31, are vulnerable to Information Exposure via the valueOf() function which allows to reproduce the last id generated.

Affected packages

PackageVersions
npm · nanoidintroduced 3.0.0, fixed 3.1.31

References

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database