GHSA-qq5r-98hh-rxc9

Apache Tomcat - Security constraint bypass with HTTP/0.9

En bref

Publiée
Mise à jour
CVE
CVE-2026-24733
Alias
BIT-tomcat-2026-24733
CVSS_V4
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N/E:U

Description

Improper Input Validation vulnerability in Apache Tomcat. Tomcat did not limit HTTP/0.9 requests to the GET method. If a security constraint was configured to allow HEAD requests to a URI but deny GET requests, the user could bypass that constraint on GET requests by sending a (specification invalid) HEAD request using HTTP/0.9. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.14, from 10.1.0-M1 through 10.1.49, from 9.0.0.M1 through 9.0.112. Older, EOL versions are also affected. Users are recommended to upgrade to version 11.0.15 or later, 10.1.50 or later or 9.0.113 or later, which fixes the issue.

Paquets affectés

PaquetVersions
Maven · org.apache.tomcat:tomcat-coyoteintroduced 11.0.0-M1, fixed 11.0.15
Maven · org.apache.tomcat:tomcat-coyoteintroduced 10.1.0-M1, fixed 10.1.50
Maven · org.apache.tomcat:tomcat-coyoteintroduced 0, fixed 9.0.113

Références

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database