GHSA-qmq6-jpvg-j547
Magento is affected by an os command injection via the Data collection endpoint
En bref
- Publiée
- Mise à jour
- CVE
- CVE-2021-36024
- CVSS_V3
- CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H
Description
Magento Commerce versions 2.4.2 (and earlier), 2.4.2-p1 (and earlier) and 2.3.7 (and earlier) are affected by an Improper Neutralization of Special Elements Used In A Command via the Data collection endpoint. An attacker with admin privileges can upload a specially crafted file to achieve remote code execution.
Paquets affectés
| Paquet | Versions |
|---|---|
| Packagist · magento/project-community-edition | introduced 0, last affected 2.0.2 |
| Packagist · magento/community-edition | introduced 0, fixed 2.3.7-p1 |
| Packagist · magento/community-edition | 2.3.7 |
| Packagist · magento/community-edition | introduced 2.4.2-p1, fixed 2.4.2-p2 |
| Packagist · magento/community-edition | 2.4.2 |
Références
- https://nvd.nist.gov/vuln/detail/CVE-2021-36024 ADVISORY
- https://github.com/magento/magento2 PACKAGE
- https://helpx.adobe.com/security/products/magento/apsb21-64.html WEB
Sources
| Source | Licence |
|---|---|
| OSV.dev | CC-BY 4.0 — GitHub Advisory Database |