GHSA-qj2w-mw2r-pv39

RubyGems Deserialization of Untrusted Data vulnerability

At a glance

Published
Updated
CVE
CVE-2018-1000074
CVSS_V3
CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Description

RubyGems version Ruby 2.2 series: 2.2.9 and earlier, Ruby 2.3 series: 2.3.6 and earlier, Ruby 2.4 series: 2.4.3 and earlier, Ruby 2.5 series: 2.5.0 and earlier, prior to trunk revision 62422 contains a Deserialization of Untrusted Data vulnerability in owner command that can result in code execution. This attack requires the victim to run the `gem owner` command on a gem with a specially crafted YAML file. This vulnerability is fixed in 2.7.6.

Affected packages

PackageVersions
RubyGems · rubygems-updateintroduced 0, fixed 2.7.6
Maven · org.jruby:jruby-stdlibintroduced 0, fixed 9.1.16.0

References

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database