GHSA-qhxp-v273-g94h

sanitize-html is vulnerable to XSS through incomprehensive sanitization

En bref

Publiée
Mise à jour
CVE
CVE-2019-25225
CVSS_V3
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

Description

`sanitize-html` prior to version 2.0.0-beta is vulnerable to Cross-site Scripting (XSS). The `sanitizeHtml()` function in `index.js` does not sanitize content when using the custom `transformTags` option, which is intended to convert attribute values into text. As a result, malicious input can be transformed into executable code.

Paquets affectés

PaquetVersions
npm · sanitize-htmlintroduced 0, fixed 2.0.0-beta

Références

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database