GHSA-qgfr-5hqp-vrw9

Path Traversal in decompress

At a glance

Published
Updated
CVE
CVE-2020-12265
CVSS_V3
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Description

Versions of `decompress` prior to 4.2.1 are vulnerable to Arbitrary File Write. The package fails to prevent extraction of files with relative paths, allowing attackers to write to any folder in the system by including filenames containing`../`. ## Recommendation Upgrade to version 4.2.1 or later.

Affected packages

PackageVersions
npm · decompressintroduced 0, fixed 4.2.1

References

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database