GHSA-qg3g-2mgh-33j8

Sensitive Data Exposure in msrcrypto

En bref

Publiée
Mise à jour
CVE
CVE-2018-8319
CVSS_V3
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Description

Versions of `msrcrypto` prior to 1.4.1 are vulnerable to Sensitive Data Exposure. The package's Elliptic Curve Cryptography (ECC) implementation may leak information about a server's private ECC key. It can also allow attackers to craft invalid ECDSA signatures that pass as valid. There is no published proof-of-concept for this vulnerability. ## Recommendation Upgrade to version 1.4.1 or later.

Paquets affectés

PaquetVersions
npm · msrcryptointroduced 0, fixed 1.4.1

Références

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database