GHSA-qf28-8hc6-vwrp
Payload: Prototype pollution in Payload Import Export plugin
En bref
- Publiée
- Mise à jour
- CVE
- CVE-2026-105844
- CVSS_V4
- CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N
Description
### Impact An unauthenticated user could cause unintended application behavior when the Import Export plugin is enabled, allowing an attacker to submit and execute remote code (RCE). Applications that do not use `@payloadcms/plugin-import-export` are not affected. ### Patches Users should upgrade Payload packages to `>= 3.88.0` or `>= 4.0.0-canary.27.` ### Workarounds Upgrading is recommended. Until then, disable the Import Export plugin or restrict access to its endpoints.
Paquets affectés
| Paquet | Versions |
|---|---|
| npm · @payloadcms/plugin-import-export | introduced 3.0.0, fixed 3.88.0 |
| npm · @payloadcms/plugin-import-export | introduced 4.0.0-canary.0, fixed 4.0.0-canary.27 |
Références
- https://github.com/payloadcms/payload/security/advisories/GHSA-qf28-8hc6-vwrp WEB
- https://github.com/payloadcms/payload/commit/a742140ab4fca3160f7f83e9e7d996552ffc3b5a WEB
- https://github.com/payloadcms/payload PACKAGE
- https://github.com/payloadcms/payload/releases/tag/v3.88.0 WEB
Sources
| Source | Licence |
|---|---|
| OSV.dev | CC-BY 4.0 — GitHub Advisory Database |