GHSA-qcgc-6q86-7x2p
AEM WCM Core Components CVG Image vulnerable to Reflected Cross-site Scripting
At a glance
- Published
- Updated
- CVE
- CVE-2022-35697
- CVSS_V3
- CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
Description
Core Components version 2.20.6 (and earlier) suffer from a reflected cross-site scripting (XSS) vulnerability in `AdaptiveImageServlet` via SVG images. An attacker with author access can upload a special crafted SVG image (including a malicious Javascript) and obtain a link that, when loaded by another authenticated users, will execute the malicious script and gain access to other user's session. The issue has been resolved in 2.20.8. There are currently no known workarounds.
Affected packages
| Package | Versions |
|---|---|
| Maven · com.adobe.cq:core.wcm.components.core | introduced 0, fixed 2.20.8 |
References
- https://github.com/adobe/aem-core-wcm-components/security/advisories/GHSA-qcgc-6q86-7x2p WEB
- https://nvd.nist.gov/vuln/detail/CVE-2022-35697 ADVISORY
- https://github.com/adobe/aem-core-wcm-components PACKAGE
Sources
| Source | Licence |
|---|---|
| OSV.dev | CC-BY 4.0 — GitHub Advisory Database |