GHSA-q74x-qqhr-f8rx

Apache Tomcat Cross-site scripting (XSS) vulnerability

At a glance

Published
Updated
CVE
CVE-2008-1232

Description

Cross-site scripting (XSS) vulnerability in Apache Tomcat 4.1.0 through 4.1.37, 5.5.0 through 5.5.26, and 6.0.0 through 6.0.16 allows remote attackers to inject arbitrary web script or HTML via a crafted string that is used in the message argument to the HttpServletResponse.sendError method.

Affected packages

PackageVersions
Maven · org.apache.tomcat:tomcatintroduced 4.1.0, fixed 4.1.38
Maven · org.apache.tomcat:tomcatintroduced 5.5.0, fixed 5.5.27
Maven · org.apache.tomcat:tomcatintroduced 6.0.0, fixed 6.0.17

References

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database