GHSA-q742-qvgc-gc2f

TinyMCE Cross-Site Scripting (XSS) vulnerability using through data-mce- prefixed src, href, style attributes

At a glance

Published
Updated
CVE
CVE-2026-47759
CVSS_V3
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:N

Description

### Impact Stored XSS vulnerability via unsanitized data-mce-* attributes (data-mce-href, data-mce-src, data-mce-style). Allows attackers to inject malicious values that override safe attributes during serialization, bypassing validation. ### Patches Patched by stripping unsafe data-mce-* attributes during parsing. Users should upgrade to the latest patched versions (5 LTS, 7.x, 8.x). ### Workarounds No official workaround available. ### Fix To avoid this vulnerability: Upgrade to TinyMCE 8.5.1 or higher. Upgrade to TinyMCE 7.9.3 or higher. Upgrade to TinyMCE 5.11.1 LTS or higher for TinyMCE 5.x (only available as part of commercial [long-term support](https://www.tiny.cloud/long-term-support/) contract). ### Acknowledgements Tiny thanks [Tadi Kadango](https://github.com/mtrill47) ([website](https://tadiwakadango.com/)) and [Ivan Babenko](https://github.com/he1d3n) for their help identifying this vulnerability.

Affected packages

PackageVersions
npm · tinymceintroduced 0, last affected 5.10.9
npm · tinymceintroduced 6.0.0, fixed 7.9.3
npm · tinymceintroduced 8.0.0, fixed 8.5.1
NuGet · TinyMCEintroduced 0, last affected 5.10.9
NuGet · TinyMCEintroduced 6.0.0, fixed 7.9.3
NuGet · TinyMCEintroduced 8.0.0, fixed 8.5.1
Packagist · tinymce/tinymceintroduced 0, last affected 5.10.9
Packagist · tinymce/tinymceintroduced 6.0.0, fixed 7.9.3
Packagist · tinymce/tinymceintroduced 8.0.0, fixed 8.5.1

References

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database