GHSA-q3rp-555r-hh6r

Jenkins allows Cross-Site Scripting (XSS)

At a glance

Published
Updated
CVE
CVE-2011-4344
CVSS_V4
CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:A/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N

Description

Cross-site scripting (XSS) vulnerability in Jenkins Core in Jenkins before 1.438, and 1.409 LTS before 1.409.3 LTS, when a stand-alone container is used, allows remote attackers to inject arbitrary web script or HTML via vectors related to error messages.

Affected packages

PackageVersions
Maven · org.jenkins-ci.main:jenkins-coreintroduced 0, fixed 1.409.3
Maven · org.jenkins-ci.main:jenkins-coreintroduced 1.410, fixed 1.438

References

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database