GHSA-q3rp-555r-hh6r
Jenkins allows Cross-Site Scripting (XSS)
At a glance
- Published
- Updated
- CVE
- CVE-2011-4344
- CVSS_V4
- CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:A/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N
Description
Cross-site scripting (XSS) vulnerability in Jenkins Core in Jenkins before 1.438, and 1.409 LTS before 1.409.3 LTS, when a stand-alone container is used, allows remote attackers to inject arbitrary web script or HTML via vectors related to error messages.
Affected packages
| Package | Versions |
|---|---|
| Maven · org.jenkins-ci.main:jenkins-core | introduced 0, fixed 1.409.3 |
| Maven · org.jenkins-ci.main:jenkins-core | introduced 1.410, fixed 1.438 |
References
- https://nvd.nist.gov/vuln/detail/CVE-2011-4344 ADVISORY
- https://github.com/jenkinsci/winstone/commit/410ed3001d51c689cf59085b7417466caa2ded7b.patch WEB
- https://github.com/jenkinsci/jenkins PACKAGE
- https://web.archive.org/web/20200229031004/https://www.securityfocus.com/bid/50786 WEB
- http://groups.google.com/group/jenkinsci-advisories/msg/1b94588f90f876b5?dmode=source&output=gplain WEB
- http://openwall.com/lists/oss-security/2011/11/23/5 WEB
- http://openwall.com/lists/oss-security/2011/11/23/6 WEB
- http://www.cloudbees.com/jenkins-advisory/jenkins-security-advisory-2011-11-08.cb WEB
Sources
| Source | Licence |
|---|---|
| OSV.dev | CC-BY 4.0 — GitHub Advisory Database |