GHSA-q2c6-c6pm-g3gh

Arbitrary Code Execution in handlebars

En bref

Publiée
Mise à jour

Description

Versions of `handlebars` prior to 3.0.8 or 4.5.3 are vulnerable to Arbitrary Code Execution. The package's lookup helper fails to properly validate templates, allowing attackers to submit templates that execute arbitrary JavaScript in the system. It is due to an incomplete fix for a [previous issue](https://www.npmjs.com/advisories/1316). This vulnerability can be used to run arbitrary code in a server processing Handlebars templates or on a victim's browser (effectively serving as Cross-Site Scripting). ## Recommendation Upgrade to version 3.0.8, 4.5.3 or later.

Paquets affectés

PaquetVersions
npm · handlebarsintroduced 0, fixed 3.0.8
npm · handlebarsintroduced 4.0.0, fixed 4.5.3

Références

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database